题目来源:

https://vjudge.net/contest/292780#problem/E

http://acm.hdu.edu.cn/showproblem.php?pid=1242

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. 

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards. 

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.) 

Input

First line contains two integers stand for N and M. 

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file. 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

题意:

a:天使

x:守卫

r:天使的friend

# :墙

. :路

天使关在有守卫的牢中,他的朋友们(Angel's friends)去救他,意味着有多个r!!。

从a开始,走到最近的朋友结束。

刚开始的时候没注意是多个friends,普通的队列做bfs只能得到步数最少的解法,而不是时间最少的,结束条件得改一改。

(乍一看,这不就是坦克大战吗,可是优先队列咋用来写bfs??,,发现当时就没写坦克大战,比赛时候一直在整dfs最后才想起还有一个bfs,太久没写搜索了,一定补补

参考代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<vector>
#include<queue>
#include<stack>
#include<cstring>
#include<map>
#include<set>
#include <algorithm>
#define lson l,mid,root<<1
#define rson mid+1,r,root<<1|1
const double pi=acos(-1);
#define inf 0x3f3f3f3f
#define N 1005
#define eps 1e-5
using namespace std;
int next_x[4]={1,0,-1,0};
int next_y[4]={0,1,0,-1};
char mapp[N][N];
bool book[N][N],falg;
int sx,sy,n,m,ans;
struct node
{
	int x,y,step;
};
void bfs()
{
   queue <node > Q ;
	node a;
	a.x=sx;
	a.y=sy;
	a.step=0;
	Q.push(a);
	while(!Q.empty())
	{
		node f;
		f=Q.front();
		Q.pop();
		for(int i=0;i<4;i++)
		{
			int tx=f.x+next_x[i];
			int ty=f.y+next_y[i];
			if(tx<1||ty<1||tx>n||ty>m||mapp[tx][ty]=='#') continue;
			if(book[tx][ty]==0)//找到最少时间的最近的r
			{
				book[tx][ty]++;
				node temp;
				temp.x=tx;
				temp.y=ty;
				temp.step=f.step+1;
				if(mapp[tx][ty]=='x')
					temp.step++;
				Q.push(temp);
				if(mapp[tx][ty]=='r')
				{
					if(temp.step<ans)ans=temp.step;
					falg=1;
				}
			}
		}
	}
	return;
}
int main()
{

	while(~scanf("%d %d",&n,&m))
	{
		falg=0;
		memset(book,0,sizeof(book));
		int sb=0;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				cin>>mapp[i][j];//cin读入不需要考虑换行和回车
				if(mapp[i][j]=='a')//r有多个从a到最近的r!!
				{
					sx=i;
					sy=j;
				}
			}
		}
		book[sx][sy]=1;
		ans=inf;
		bfs();
		if(!falg)
			printf("Poor ANGEL has to stay in the prison all his life.\n");
		else
			printf("%d\n",ans);
	}
	return 0;
}