题目链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=131
Time Limit: 1000MS Memory Limit: 10000K

Description

You are to write a program that has to generate all possible words from a given set of letters. 
Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba". 
In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order. 

Input

The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.

Output

For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.

Sample Input

3
aAb
abc
acba

Sample Output

Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa

Hint

An upper case letter goes before the corresponding lower case letter. 
So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.

Problem solving report:

Description: 按照'A'<'a'<'B'<'b'<...<'Z'<'z'的顺序输出所有全排列。
Problem solving: 使用STL的排列next_permutation,但是此题不是字典序,所以需要编写cmp函数来使用next_permutation。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
bool cmp(char a, char b) {
    if (tolower(a) != tolower(b))
        return tolower(a) < tolower(b);
    return a < b;
}
int main() {
    int t, len;
    char str[105];
    scanf("%d", &t);
    while (t--) {
        scanf("%s", str);
        len = strlen(str);
        sort(str, str + len, cmp);
        do {
            printf("%s\n", str);
        }while (next_permutation(str, str + len, cmp));
    } 
    return 0;
}