2021-12-25

A 10yen Stamp

题目:

高桥想给圣诞老人寄一封信。 他有一个信封,上面贴着 X 日元(日本货币)邮票。
要交付给圣诞老人,信封必须有总价值至少为 Y 日元的邮票。
高桥会多放一些 10 日元的邮票,这样信封上的邮票总价值至少为 Y 日元。
高桥至少需要在信封上再贴多少张 10 日元邮票?

在80日元邮票上加上0个10日元邮票后,总共是80日元,比所需的94日元少。
在80日元的邮票上加上一张10日元的邮票后,总共是90日元,比所需的94日元少。
在80日元邮票上加上两张10日元邮票后,总共是100日元,不低于所需金额94日元。

测试样例:

Sample Input 1 
80 94
Sample Output 1 
2

【code】:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef long double ld;
typedef pair<int,int> pii;

const int inf=0x3f3f3f3f;
const int maxn=1e6+5;
void solve(){
   
    int a, b;
    cin >> a >> b;
    if(b-a<=0)
        cout << "0";
    else{
   
        cout << (int)ceil((b - a)*1.0 / 10);
    }
}

int main(){
   
    ios::sync_with_stdio(0);
    int t;
    t = 1;
    while(t--)solve();
    return 0;
}

B - A Reverse

题目:

问题陈述
给定整数 L、R 和由小写英文字母组成的字符串 S。
在反转(顺序)第 L 个到第 R 个字符后打印此字符串。

Sample Input 1 
3 7
abcdefgh

Sample Output 1 
abgfedch

【code】:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef long double ld;
typedef pair<int,int> pii;

const int inf=0x3f3f3f3f;
const int maxn=1e6+5;
void solve(){
   
    int a, b;
    cin >> a >> b;
    string s;
    cin >> s;

    for (int i = 0; i < a-1;i++){
   
        cout << s[i];
    }
    for (int i = b-1; i >= a-1;i--){
   
        cout << s[i];
    }
    for (int i = b ; i < s.size(); i++)
    {
   
        cout << s[i];
    }
}

int main(){
   
    ios::sync_with_stdio(0);
    int t;
    t = 1;
    while(t--)solve();
    return 0;
}