Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
输入描述:
There’s only one test case in the input. Each line is a command, “GET” or “PUT”, which means getting message or putting message. If the command is “PUT”, there’re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
输出描述:
For each “GET” command, output the command getting from the message queue with the name and parameter in one line. If there’s no message in the queue, output “EMPTY QUEUE!”. There’s no output for “PUT” command.
样例输入:
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
样例输出:
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!
代码:

#include <bits/stdc++.h>
using namespace std;
typedef pair<int,int> P;
char que[60001][50];
int main()
{
    priority_queue <P,vector<P>,greater<P> > q;
    char zl[5];int t=0;
    P  p,u;
    while(scanf("%s",zl)!=-1)
    {
        getchar();
        if(zl[0]=='G')
        {
            if(q.size()==0)
                puts("EMPTY QUEUE!");
            else
            {
                u=q.top();
                int x=u.second;
                cout<<que[x]<<endl;
                q.pop();
            }
        }
        else if(zl[0]=='P')
        {
            for(int i=0,n=0;;i++)
            {
                char m;m=getchar();

                if(m==' ')
                n++;
                if(n==2)
                    break;
                que[t][i]=m;    
            }
            int x;
            cin>>x;
            p.first=x;
            p.second=t;
            q.push(p);
            t++;
        }
    }
    return 0;
}