问题 B: 【高精度】简单高精度加法

时间限制: 1 Sec  内存限制: 64 MB

题目描述

修罗王解决了计算机的内存限制问题,终于可以使用电脑进行大型的魔法运算了,他交给邪狼的第一个任务是计算两个非负整数A、B的和,其中A和B的位数在5000位以内。

 

输入

共两行数据,第一行为一个非负整数A,第二行为一个非负整数B,A、B的位数均在5000以内。

 

输出

输出一个非负数,即两数之和。

 

样例输入

复制样例数据

1111111111
2222222222

样例输出

3333333333

 

/**/
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cctype>
#include <iostream>
#include <algorithm>
#include <map>
#include <set>
#include <vector>
#include <string>
#include <stack>
#include <queue>

typedef long long LL;
using namespace std;

char a[50005], b[50005];
int ans[50005];

int main()
{
	//freopen("in.txt", "r", stdin);
	//freopen("out.txt", "w", stdout);

	scanf("%s %s", a, b);
	int lena = strlen(a), lenb = strlen(b);
	int cnt = 0;
	while(lena - cnt > 0 || lenb - cnt > 0){
		if(lena - cnt > 0) ans[cnt] += a[lena - cnt - 1] - '0';
		if(lenb - cnt > 0) ans[cnt] += b[lenb - cnt - 1] - '0';
		ans[cnt + 1] += ans[cnt] / 10;
		ans[cnt++] %= 10;
	}
	while(ans[cnt]) cnt++;
	for (int i = cnt - 1; i >= 0; i--){
		printf("%d", ans[i]);
	}
	printf("\n");

	return 0;
}
/**/