I Hate It

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input

本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取’Q’或’U’) ,和两个正整数A,B。
当C为’Q’的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为’U’的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

Output

对于每一次询问操作,在一行里面输出最高成绩。

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output

5
6
5
9

Hint

Huge input,the C function scanf() will work better than cin

思路:

一道线段树的题目,其实只要会线段树的模板就够了,首先就是建树,然后每次都更新树的结点,最后进行查询操作,在这里father的作用就是知道i属于哪一个结点

#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn = 2e+6 + 10;
const int maxnnode = 1 << 19;
struct NODE {
	int value;
	int left;
	int right;
};
NODE node[maxnnode];
int father[maxn];
void BulidTree(int i, int l, int r) {
	node[i].left = l;
	node[i].right = r;
	node[i].value = 0;
	if (l == r) {
		father[l] = i;
		return ;
	}
	BulidTree(i << 1, l, (int)(floor((l + r) / 2.0)));
	BulidTree((i << 1) + 1, (int)(floor((l + r) / 2.0)) + 1, r);
}
void UpdataTree(int x) {
	if (x == 1) return ;
	int y = x >> 1;
	int a = node[y << 1].value;
	int b = node[(y << 1) + 1].value;
	node[y].value = max(a, b);
	UpdataTree(y);
}
int ans = 0;
void Query(int i, int l, int r) {
	if (node[i].left == l && node[i].right == r) {
		ans = max(ans, node[i].value);
		return ;
	}
	i <<= 1;
	if (l <= node[i].right) {
		if (r <= node[i].right) Query(i, l, r);
		else Query(i, l, node[i].right);
	} 
	i += 1;
	if (r >= node[i].left) {
		if (l >= node[i].left) Query(i, l, r);
		else Query(i, node[i].left, r);
	}
}
int main() {
	int n, m, k;
	while (scanf("%d %d", &n, &m) != EOF) {
		BulidTree(1, 1, n);
		for (int i = 1; i <= n; i++) {
			scanf("%d", &k);
			node[father[i]].value = k;
			UpdataTree(father[i]);
		}
		char s;
		int a, b;
		while (m--) {
			getchar();
			scanf("%c %d %d", &s, &a, &b);
			if (s == 'Q') {
				ans = 0;
				Query(1, a, b);
				printf("%d\n", ans);
			} else {
				node[father[a]].value = b;
				UpdataTree(father[a]);
			}
		}
	}
	return 0;
}