Charm Bracelet

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23
  
裸01背包……
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const long N = 3600, M = 13000;
long f[M];
long n, m, w, c;
long max(long a, long b)
{
    return a > b ? a : b;
}
void ZeroOnePack(long c, long w)
{
    for (long i = m; i >= c; i--)
    {
        f[i] = max(f[i - 1], f[i]);
        f[i] = max(f[i], f[i - c] + w);
    }
}

int main()
{
    while (scanf("%d%d", &n, &m) != EOF)
    {
        memset(f, 0, sizeof(f));
        for (long i = 1; i <= n; i++)
        {
            scanf("%d%d", &c, &w);
            ZeroOnePack(c, w);
        }
        printf("%d\n", f[m]);
    }
    return 0 ;
}