Billboard

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.
On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.
Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.
When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.
If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).
Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).
The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.
Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
Sample Input
3 5 5 2 4 3 3 3
Sample Output
1 2 1 3 -1 题目大意: 有一块h*w的矩形广告板,要往上面贴广告, 给n个1*wi的广告, 要求广告要尽量往上贴并且尽量靠左 ,求第n个广告的所在的位置,不能贴则为-1。 线段树,相当于将广告版选=旋转了一下,记录每一个区间最多还剩了w可以贴广告, 然后就是很明显线段树操作了!!
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;
int tree[800005];
int w, h, n;
void build (int p, int l, int r)
{
	tree[p] = w;
	if (l == r) return;
	int mid = (l + r) / 2;
	build(p * 2, l, mid);
	build(p * 2 + 1, mid + 1, r);
}
int find(int p, int l,int r, int x) 
{
	if (l == r) {tree[p] -= x; return l;}
	int mid = (l + r) / 2;
	int re = 0;
	if(x <= tree[p * 2]) re  = find(p * 2, l, mid, x); 
	else re  = find(p * 2 + 1, mid + 1, r, x);
	tree[p] = max(tree[p * 2], tree[p * 2 + 1]); 
	return re;
}
int main()
{
	while (scanf("%d%d%d", &h, &w, &n) != EOF)
	{
		if(h > n) h = n;
        build(1, 1, h);  
        for(int i = 1; i <= n; i++)  
        {  
        	int x;
            scanf("%d", &x);  
            if(x > tree[1])  printf("-1\n");  
            else  printf("%d\n", find(1, 1, h, x));  
        }  
	}
	
	return 0;
}