Max Sum 

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

此题最大子序和,网上的dp常用分治思想,在此笔者给出联机算法,其中道理只可意会不可言传,代码如下:

#include<bits/stdc++.h>
using namespace std;
#define mm(a) memset(a,0,sizeof(a))
#define ll long long
int n,ans[100005];
int main()
{
    int t;
    cin>>t;
    for(int j=1; j<=t; j++)
    {
        mm(ans);
        cin>>n;
        for(int i=1; i<=n; i++)
            cin>>ans[i];
        int b=1,e=1,sum=0,maxn=-100000000,temp=1;
        for(int i=1; i<=n; i++)
        {
            if(sum>=0)
                sum+=ans[i];
            else
            {
                sum=ans[i];
                temp=i;
            }
            if(sum>maxn)
            {
                maxn=sum;
                b=temp;
                e=i;
            }
        }
        cout<<"Case "<<j<<":\n";
        cout<<maxn<<" "<<b<<" "<<e<<endl;
        if(j!=t)
            cout<<endl;
    }
    return 0;
}