A + B Problem II

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1:

1 + 2 = 3

 

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

#include<stdio.h>
#include<string.h>
char a[1010],b[1010];
int sum[1010];
int main()
{
	int i,j,k,s,lena,lenb,t,d;
	while(scanf("%d",&t)!=EOF)
	{
		d=t;
		s=0;
		while(t--)
		{
			s++;
			scanf("%s%s",a,b);
			lena=strlen(a);
			lenb=strlen(b);
			memset(sum,0,sizeof(sum));
			k=0;
			for(i=lena-1,j=lenb-1;i>=0&&j>=0;i--,j--)
			{
				sum[k]=a[i]-'0'+b[j]-'0'+sum[k];
				if(sum[k]>=10)
				{
				sum[k]=sum[k]-10;
				sum[k+1]=sum[k+1]+1;
				}
				k++;
			}
			while(j>=0)
			{
				sum[k]=b[j--]-'0'+sum[k];
				if(sum[k]>=10)
				{
					sum[k]=sum[k]-10;
					sum[k+1]=sum[k+1]+1;
				}
				k++;
			}
				
			while(i>=0)
			{
				sum[k]=a[i--]-'0'+sum[k];
				if(sum[k]>=10)
				{
					sum[k]=sum[k]-10;
					sum[k+1]=sum[k+1]+1;
				}
				k++;
			}
				
			k=1009;
			while(k--)
			{
				if(sum[k]!=0)
					break;
			}
			printf("Case %d:\n",s);
			printf("%s + %s = ",a,b);
			if(k==-1)
				printf("0");
			for(i=k;i>=0;i--)
				printf("%d",sum[i]);
			printf("\n");
			if(s!=d)
				printf("\n");
		}
	}
	return 0;
}