Description:

在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?

已经告诉你了,这是个DP的题目,你能AC吗?

Input:

输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。

Output:

对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。

Sample Input:

1
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output:

30

题目链接

动态规划有点像记忆化递归,每一层结点的最大数字之和之和上一层结点的最大数字之和相关。

AC代码:

#include <bits/stdc++.h>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define pb push_back
#define mp make_pair
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int> P;
const int INF = 0x3f3f3f3f;
const int maxn = 1e2+5;
const int mod = 1e9+7;
const double eps = 1e-8;
const double pi = asin(1.0)*2;
const double e = 2.718281828459;
void fre() {
    freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
}

int t;
int n;
int ans;
int dp[maxn][maxn] = {0};

int main(){
    //fre();
    scanf("%d", &t);
    while (t--) {
        ans = -1;
        scanf("%d", &n);
        for (int i = 1; i <= n; ++i) {
            for (int j = 1; j <= i; ++j) {
                scanf("%d", &dp[i][j]);
                dp[i][j] += max(dp[i - 1][j - 1], dp[i - 1][j]);
                if (i == n && dp[i][j] > ans) {
                    ans = dp[i][j];
                }
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}