https://cn.vjudge.net/problem/ZOJ-1163

One curious child has a set of N little bricks. From these bricks he builds different staircases. Staircase consists of steps of different sizes in a strictly descending order. It is not allowed for staircase to have steps equal sizes. Every staircase consists of at least two steps and each step contains at least one brick. Picture gives examples of staircase for N=11 and N=5:

Your task is to write a program that reads from input numbers N and writes to output numbers Q - amount of different staircases that can be built from exactly N bricks.

 

Input



Numbers N, one on each line. You can assume N is between 3 and 500, both inclusive. A number 0 indicates the end of input.

 

 

 

Output



Numbers Q, one on each line.

 

 

Sample Input






 

 

 

Sample Output



1
2

dp[i][j]代表i块积木,底层块数不大于j的种数

dp[i][j]=dp[i-j][j-1]+dp[i][j-1]

1.底层块数小于j

2.底层块数等于j

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<string>
#include<cstring>
#include<map>
#include<vector>
#include<set>
#include<list>
#include<stack>
#include<queue>
using namespace std;
typedef long long ll;
ll dp[505][505];
int main(){
	for(int i=0;i<=500;i++) dp[0][i]=1;
	for(int i=1;i<=500;i++){
		for(int j=1;j<=500;j++){
			if(i<j) dp[i][j]=dp[i][j-1];
			else dp[i][j]=dp[i-j][j-1]+dp[i][j-1];
		}
	}
    int n;
    while(~scanf("%d",&n)&&n){
    	printf("%lld\n",dp[n][n]-1);
	}
	return 0;
}