Description:

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

这个题就是说地图上分布着n台坏的电脑,修好一台就能用一台,两台好的电脑之间距离小于d就可以通信,距离过远的两台之间可以通过第三台好的电脑中转通信,然后现在随修电脑随问你指定的两台能不能通信。

思路也很简单:对于目前所有修好的电脑,根据上述规则能互相通信的组成一棵棵并查集中的树,然后对指定的两个点查询就可以了。

其中的难点就是区分出好电脑和坏电脑,以及注意距离判断,要将这些与并查集揉在一起用。
这里用use数组区分好坏,InRange函数判断距离。

示例代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <algorithm>
typedef long long ll;
const int INF = 0x3f3f3f3f;
using namespace std;
const int N = 1050;

struct node
{
    int pre;
    int x, y;
}P[N];

int use[N];

void init(int n)
{
    for(int i = 1; i <= n; i++)
        P[i].pre = i;
    memset(use, 0, sizeof(use));
}

int Find(int x)
{
    int r = x;
    while(r != P[r].pre)
        r = P[r].pre;
    int i = x, j;
    while(i != r) //路径压缩
    {
        j = P[i].pre;
        P[i].pre = r;
        i = j;
    }
    return r;
}

void Join(node p1, node p2)
{
    int root1, root2;
    root1 = Find(p1.pre);
    root2 = Find(p2.pre);
    if(root1 != root2)
        //if((p1.x - p2.x) * (p1.x - p2.x) + (p1.y - p2.y) * (p1.y - p2.y) <= d * d)
            P[root2].pre = root1;
}

bool InRange(node p1, node p2, int d)
{
    if((p1.x-p2.x)*(p1.x-p2.x) + (p1.y-p2.y)*(p1.y-p2.y) <= d*d)
        return true;
    return false;
}

int main()
{
    int n, d;
    scanf("%d %d", &n, &d);
    init(n);
    for(int i = 1; i <= n; i++)
        scanf("%d %d", &P[i].x, &P[i].y);
    char ch;
    while(~scanf("\n%c", &ch))
    {
        if(ch == 'O')
        {
            int rep;
            scanf("%d", &rep);
            use[rep] = 1;
            for(int i = 1; i <= n; i++)
                if(use[i] && i != rep)
                    if(InRange(P[i], P[rep], d))
                        Join(P[i], P[rep]);
        }
        else
        {
            int con1, con2;
            scanf("%d %d", &con1, &con2);
            if(Find(con1)==Find(con2))
                printf("SUCCESS\n");
            else printf("FAIL\n");
        }
    }
    return 0;
}