Let's play a traditional game Nim. You and I are seated across a table and we have a hundred stones on the table (we know the number of stones exactly). We play in turn and at each turn, you or I can remove on to four stones from the heap. You play first and the one who removed the last stone loses. 
In this game, you have a winning strategy. To see this, you first remove four stones and leave 96 stones. No matter how I play, I will end up with leaving 92 - 95 stones. Then you will in turn leave 91 stones for me (verify this is always possible). This way, you can always leave 5k+1 stones for me and finally I get the last stone, sigh. If we initially had 101 stones, on the other hand, I have a winning strategy and you are doomed to lose. 

Let's generalize the game a little bit. First, let's make it a team game. Each team has n players and the 2n players are seated around the table, with each player having opponents at both sides. Turn around the table so the two teams play alternately. Second, let's vary the maximum number of stones each player can take. That is, each player has his/her own maximum number of stones he/she can take at each turn (The minimum is always one). So the game is asymmetric and may even be unfair. 

In general, when played between two teams of experts, the outcome of a game is completely determined by the initial number of stones and the maximum number of stones each player can take at each turn. In other words, either team has a winning strategy. 

You are the head-coach of a team. In each game, the umpire shows both teams the initial number of stones and the maximum number of stones each player can take at each turn. Your team plays first. Your job is, given those numbers, to instantaneously judge whether your team has a winning strategy. 

Incidentally, there is a rumor that Captain Future and her officers of Hakodate-maru love this game, and they are killing their time playing it during their missions. You wonder where the stones are? Well, they do not have stones but do have plenty of balls in the fuel containers! 

Input

The input is a sequence of lines, followed by the last line containing a zero. Each line except the last is a sequence of integers and has the following format. 

n S M1 M2 . . . M2n 

where n is the number of players in a team, S the initial number of stones, and Mi the maximum number of stones ith player can take. 1st, 3rd, 5th, ... players are your team's players and 2nd, 4th, 6th, ... the opponents. Numbers are separated by a single space character. You may assume 1 <= n <= 10, 1 <= Mi <= 16, and 1 <= S < 2^13. 

Output

The output should consist of lines each containing either a one, meaning your team has a winning strategy, or a zero otherwise. 

Sample Input

1 101 4 4
1 100 4 4
3 97 8 7 6 5 4 3
0

Sample Output

0
1
1

 题意:两支队伍A,B,相间而坐,意思是A(1,3,5,7,9...)B(2,4,6,8,10...),每个人一个。给你一堆石头S个

从第一个人开始取,每人最少取1个最多取个,问A队伍有没有必胜策略。

题解:由于数据比较小,可以直接记忆化搜索,找出所有的状态来观察是不是可以必胜。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;
const int maxn=1e5+5;
int dp[1<<14][23],a[23],n;
int DP(int s,int id)
{
    if(id==2*n+1)return DP(s,1);//最后一个人拿完了再回到第一个人拿
    if(dp[s][id]!=-1)return dp[s][id];//记忆化
    if(s==0)return dp[s][id]=1;//如果石头个数为零,那么这个状态为必胜态
    for(int i=1;i<=a[id];i++)
    {
        if(s<i)break;
        if(DP(s-i,id+1)==0)
            return dp[s][id]=1;
    }
    return dp[s][id]=0;
}
int main()
{
    int S;
    while(scanf("%d",&n)&&n)
    {
        memset(dp,-1,sizeof(dp));
        scanf("%d",&S);
        for(int i=1;i<=2*n;i++)
            scanf("%d",&a[i]);
        printf("%d\n",DP(S,1));
    }
    return 0;
}