Minimum Inversion Number

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.


Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.


Output

For each case, output the minimum inversion number on a single line.


Sample Input

10
1 3 6 9 0 8 5 7 4 2


Sample Output

16


求逆序对……归并排序,线段树,树状数组都可以。

但是这个题还有点点不一样——

题目大意:

给定一串数字,求这一组数字的逆序数,而且这组数据可以改变,一次将前边的第一个数移到最后一个数的位置,构成新的数列,在诸多序列中,求出一个最小的逆序数


a[1] , a[2] , a[3]……a[n],将a[1]放到最后以后,逆序数增加a[1]之后比a[1]大的个数,减小了a[1]之前比a[1]小的,由于每个数都不一样且是0到n-1,所以 逆序数会增加 n-a[1]个,减少a[1]-1个

……于是求一遍逆序对然后一个for循环即可解决问题了



#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int a[8010], b[8010];
int tree[8010 * 4 + 17];
int n, maxn;
void build(int p, int l, int r)
{
	if (l == r){tree[p]= 0; return;}
	int mid = (l + r) / 2;
    build(p * 2, l, mid);
    build(p * 2 + 1, mid + 1, r);
    tree[p] = tree[p * 2] + tree[p * 2 + 1];
}
int find(int p, int l, int r, int x, int y)
{
	if ((x <= l) && (r <= y)) return tree[p];
	int mid = (l + r) / 2;
	int t = 0;
	if (x <= mid) t += find(p * 2, l, mid, x, y);
    if (mid < y) t += find(p * 2 + 1, mid + 1, r, x, y);
	return t;
}

void change(int p,int l,int r,int x)
{  
    if (l == r){tree[p]++;  return;}  
    int mid = (l + r) >> 1;  
    if(x <= mid)    change(p * 2, l, mid, x);
    else  change(p * 2 + 1, mid + 1, r, x);
    tree[p] = tree[p * 2] + tree[p * 2 + 1];
}
int main()
{
    while (scanf("%d", &n) != EOF)
    {
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &a[i]);
		}
		build(1, 0, n - 1);
		int sum = 0;
		for (int i = 0; i < n; i++)
		{
			sum += find(1, 0 ,n -1, a[i], n - 1);
			change(1, 0, n - 1, a[i]);  
		}
		int minn = sum;  
        for(int i = 0; i < n; i++)
        {  
            sum = sum - a[i] + (n - a[i] - 1);  
            minn = min(minn, sum);  
        }  
        printf("%d\n", minn);  
    }
	return 0;
}