题目链接:http://nyoj.top/problem/714

  • 内存限制:64MB 时间限制:1000ms

题目描述:

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

  1. The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
  2. Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
  3. Three cards are moved one at a time…
  4. This goes on until the nth and last card turns out to be the n of Spades.

This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

输入描述:

On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10  Each case consists of one line containing the integer n.  1 ≤ n ≤ 13

输出描述:

For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

样例输入:

2
4
5

样例输出:

2 1 4 3
3 1 4 5 2

解题思路

利用队列模拟这个过程。

#include <bits/stdc++.h>
using namespace std;
int main() {
    int t, n, m, p, q, a[225];
    scanf("%d", &t);
    while (t--) {
        p = q = 0;
        scanf("%d", &n);
        for (int i = n; i >= 1; i--) {
            m = i;
            a[p++] = i;
            while (m--) {
                a[p++] = a[q++];
            }
        }
        for (int i = p - 1; i >= q; i--)
            printf("%d ", a[i]);
        printf("\n");
    }
    return 0;
}