做了几道题是以前做过的;
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30

题意:

解题思路:这个题目是简单dp

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
#define ll long long
using namespace std;
const int MM=1e3+5;
int dp[MM][MM];
int a[MM][MM];
int n,m;
int t;
int main()
{
   
    cin>>t;
    for(int i=1;i<=t;i++)
    {
   
        for(int j=1;j<=i;j++)
        {
   
            cin>>a[i][j];
        }
    }
    int maxx=0;
    dp[1][1]=0;
    for(int i=t;i>=1;i--)//从后面开始
    {
   
        for(int j=1;j<=i;j++)
        {
   
            dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+a[i][j];//每两个进行比较后加当前的值 从下往上
        }
    }
    cout<<dp[1][1]<<endl;//结果是累加上来后,第一个就是最大的;
    return 0;
}