Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
Output
For each test case, you should output the text which is processed.
Sample Input
3
olleh !dlrow
m'I morf .udh
I ekil .mca
Sample Output
hello world!
I'm from hdu.
I like acm.

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t;
    while(cin >>t){    
        getchar();
        while(t--){
            char c;
            string s;
            while(c = getchar()){
                          //每找到一个单词就逆序
                if(c == '\n' || c == '\0' || c == ' '){
                    reverse(s.begin(),s.end());
                    cout <<s;
                    s="";  //再置空
                } 
                if(c == ' '){
                    cout <<" ";  //遇到空格输出空格,这样的话有几个就会输出几个
                }
                else if(c == '\n'){
                    cout <<endl;
                    break;
                }
                else s += c;//是字母时就放入s
            }
        }
    }    
}