Problem Description

The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses. 
Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students. 
Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.
However, due to statistical errors, some data are wrong and these data should be ignored. 
Smart you must know how to write a program to find the maximum number of students.

Input

The first line of the input gives the number of test cases T; T test cases follow. 
Each case begins with one line with one integer N, indicates the number of class. 
Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class. 
It’s guaranteed that at least one data is right in each test case.

Limits 
T≤100 
1≤N≤100 
0≤a,b,c,d,e,f,g≤100

Output

For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.

Sample Input



4 5 4 4 3 2 2 
5 3 1 2 0 0 0 

0 4 10 2 3 4 9 
6 12 6 3 5 3 2

Sample Output


15

Hint

In the second test case, the data uploaded by Class 1 is wrong. 
Because we can’t find a solution which satisfies the limitation. 
As for Class 2, we can calculate the number of students who only enrolled in course A is 2, 
the number of students who only enrolled in course B is 6, and nobody enrolled in course C, 
the number of students who only enrolled in courses A and B is 1, 
the number of students who only enrolled in courses B and C is 3, 
the number of students who only enrolled in courses A and C is 1, 
the number of students who enrolled in all courses is 2, 
so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.

题目大意:

输入一个数n,有n组测试数据,输入一个数m,有m组数组,每个数组里面有6个数,分别为报科目A的人数,报科目B的人数,报科目C的人数,报科目A和B的人数,报科目B和C的人数,报科目A和C的人数,报科目A,B,C的人数,求出m组数中符合规则的至少注册一门课程的学生的最大数量。

C++

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    int a,b,c,d,e,f;
    int m[8],n[8];
    cin>>a;
    while(a--)
    {
        cin>>b;
        f=-1;
        while(b--)
        {
            for(c=0;c<7;c++)
                cin>>m[c];
            m[5]=m[5]-m[6];    
            m[4]=m[4]-m[6];
            m[3]=m[3]-m[6];
            m[2]=m[2]-m[5]-m[4]-m[6];
            m[1]=m[1]-m[3]-m[4]-m[6];
            m[0]=m[0]-m[5]-m[3]-m[6];
            if(m[0]<0||m[1]<0||m[2]<0||m[3]<0||m[4]<0||m[5]<0||m[6]<0)
                continue;
            d=m[0]+m[1]+m[2]+m[3]+m[4]+m[5]+m[6];
            if(d>f)
                f=d;
        }
        cout<<f<<endl;
    }
    return 0;
}