一道经典的DP题。。。感觉学DP都是从这题开始的。。。

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
SampleInput
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
SampleOutput
30

题意就是输入一个n表示有n行,第i行有i个数,然后每次只能向下走或者右下走。从第一行到最后一行。求路径和最大是多少。。。

那么开始进入DP思维,找状态转移方程。每次向下或者向右下 移动的方向就说明了方程是
a[i] [j]=max( a [i+1] [j] ,a [i+1] [j+1] )+a[i] [j]。 这是从下往上更新的。。最后输出就是a[1][1]了。 当然也可以自上而下进行更新 不过最后的结果a[n] [j] 在最后一行,但具体在哪还需要遍历找最大一下。
下面代码展示

#include<iostream>
using namespace std;
int a[101][101];
int main()
{
    int n,i,j;
    cin>>n;
    for(i=1;i<=n;i++)
    for(j=1;j<=i;j++)
        cin>>a[i][j];
    for(i=n-1;i>=1;i--)
    {
        for(j=1;j<=i;j++)
            a[i][j]=max(a[i+1][j],a[i+1][j+1])+a[i][j];
    }
    cout<<a[1][1];
    return 0}

( cin是输入的意思 相当于c中的scanf函数,cout是输出 相当于c中的printf)。。