题目链接:传送门

Problem Description

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.

Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.

Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.

Sample Input
3 6 4
2 2.5 5 1 3 4
5 1 3.5 2 2 2
1 1 1 1 1 10
3 3 2
1 2 3
2 3 1
3 1 2


Sample Output
6 5 3 1
2 1

题目大意:

有n个人对m件衣服评价,求最高的k件衣服的编号,并且把编号从大到小输出,若评价相等,输出编号较小的。

#include<iostream>
#include<algorithm>
using namespace std;
struct ss
{
    double a;
    int b;
}m[100005];
bool cmp(ss a,ss b)
{
    return a.a>b.a;
}
int main()
{
    int a,b,c,d,e;
    double n;
    while(cin>>a>>b>>c)
    {
        int s[100005];
        for(d=0;d<b;d++)
        {
            cin>>m[d].a;
            m[d].b=d+1;
        }
        for(e=1;e<a;e++)
        {
            for(d=0;d<b;d++)
            {
                cin>>n;
                m[d].a=m[d].a+n;
            }
        }
        sort(m,m+b,cmp);
        for(d=0;d<c;d++)
            s[d]=m[d].b;
        sort(s,s+c);
        for(d=c-1;d>0;d--)
            cout<<s[d]<<" ";
        cout<<s[0]<<endl;
    }
    return 0;
}