题目链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1876
Time limit 3000 ms

Description

Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck:
Throw away the top card and move the card that is now on the top of the deck to the bottom of the deck.
Your task is to find the sequence of discarded
cards and the last, remaining card.

Input

Each line of input (except the last) contains a
number n ≤ 50. The last line contains ‘0’ and
this line should not be processed.

Output

For each number from the input produce two
lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have
leading or trailing spaces. See the sample for the
expected format.

Sample Input

7
19
10
6
0

Sample Output

Discarded cards: 1, 3, 5, 7, 4, 2
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8
Remaining card: 4
Discarded cards: 1, 3, 5, 2, 6
Remaining card: 4

Problem solving report:

Description: 给你n个牌摞成一堆,每次把第一张扔掉,然后再把第一张放到最后。输出扔掉的牌,再输出最后剩下的牌。
Problem solving: 直接模拟,注意格式就行了。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
int main() {
    int n;
    while (scanf("%d", &n), n) {
        queue <int> Q;
        for (int i = 1; i <= n; i++)
            Q.push(i);
        printf("Discarded cards:");
        while (Q.size() > 1) {
            printf(" %d", Q.front());
            Q.pop();
            Q.push(Q.front());
            Q.pop();
            if (Q.size() > 1)
                printf(",");
        }
        printf("\nRemaining card: %d\n", Q.front());
    }
    return 0;
}