7-22 堆栈模拟队列 (25 分) 设已知有两个堆栈S1和S2,请用这两个堆栈模拟出一个队列Q。

所谓用堆栈模拟队列,实际上就是通过调用堆栈的下列操作函数:

int IsFull(Stack S):判断堆栈S是否已满,返回1或0; int IsEmpty (Stack S ):判断堆栈S是否为空,返回1或0; void Push(Stack S, ElementType item ):将元素item压入堆栈S; ElementType Pop(Stack S ):删除并返回S的栈顶元素。 实现队列的操作,即入队void AddQ(ElementType item)和出队ElementType DeleteQ()。

输入格式: 输入首先给出两个正整数N1和N2,表示堆栈S1和S2的最大容量。随后给出一系列的队列操作:A item表示将item入列(这里假设item为整型数字);D表示出队操作;T表示输入结束。

输出格式: 对输入中的每个D操作,输出相应出队的数字,或者错误信息ERROR:Empty。如果入队操作无法执行,也需要输出ERROR:Full。每个输出占1行。

输入样例: 3 2 A 1 A 2 A 3 A 4 A 5 D A 6 D A 7 D A 8 D D D D T 输出样例: ERROR:Full 1 ERROR:Full 2 3 4 7 8 ERROR:Empty、

首先保证栈1是空间小的那个栈,栈2是空间大的那个栈,入队操作实际就是往栈1压栈,出队就是从栈2弹栈,队满的情况包括栈1满且栈2不空,哪怕栈2只有一个元素,可以仔细捋捋为什么。队空包括两个栈都空。

#include <cstdio>
#include <iostream>
using namespace std;

int n1,n2,d;
char s[2];
int s1[1000],s2[1000],c1,c2;
int main() {
    scanf("%d%d",&n1,&n2);
    if(n1 > n2) swap(n1,n2);
    while(scanf("%s",s) && s[0] != 'T') {
        if(s[0] == 'A') {
            scanf("%d",&d);
            if(c1 == n1) {
                printf("ERROR:Full\n");
            }
            else s1[c1 ++] = d;
        }
        else {
            if(c2) printf("%d\n",s2[-- c2]);
            else if(c1) {
                while(c1) s2[c2 ++] = s1[-- c1];
                printf("%d\n",s2[-- c2]);
            }
            else printf("ERROR:Empty\n");
        }
        if(!c2 && c1 == n1) {
            while(c1) s2[c2 ++] = s1[-- c1];
        }
    }
}