题目链接:https://vjudge.net/problem/HDU-3746

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task. 

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2: 


Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden. 
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases. 
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

题目大意:给一串字符串,问至少添加多少个字符,使得这个字符串有至少两个循环节

kmp求最小循环节https://blog.csdn.net/hao_zong_yin/article/details/77455285

因为kmp版本不一样,所以我用的这个版本中KMP最小循环节、循环周期:

定理:假设S的长度为len,则S存在最小循环节,循环节的长度L为len-(next[len-1]+1),子串为S[0…len-next[len-1]]。

(1)如果len可以被len - next[len-1]-1整除,则表明字符串S可以完全由循环节循环组成,循环周期T=len/L。

(2)如果不能,说明还需要再添加几个字母才能补全。需要补的个数是循环个数L-len%L=L-(len-L)%L=L-(next[len-1]+1)%L,L=len-next[len-1]-1。

   

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1e5+5;
char s[maxn];
int next[maxn];
void get_next(int len) {
	int j=-1;
	next[0]=-1;
	for(int i=1; i<len; i++) {
		while(j!=-1&&s[i]!=s[j+1])
			j=next[j];
		if(s[i]==s[j+1])
			j++;
		next[i]=j;
	}
}
int main() {
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%s",s);
		int len=strlen(s);
		get_next(len);
//		for(int i=0;i<len;i++)
//		printf("%d%c",next[i]," \n"[i==len-1]);
		int x=len-next[len-1]-1;//循环节的长度
		if(x!=len&&len%x==0) printf("0\n");//可以多次循环
		else printf("%d\n",x-(next[len-1]+1)%x); //取余的作用:abcab,去掉abc 
	}
    return 0;
}