Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n ≤ 30000 and 0 ≤ m ≤ 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4 2 1 2 5 10 13 11 12 14 2 0 1 2 99 2 200 2 1 5 5 1 2 3 4 5 1 0 0 0
Sample Output
4 1 1

题目大意:

有n个人,m个组,每个组有k个人曾经是一个团体(一个团体的人只要一人有病,团体所有人都可能患病)现在已经知道0号有病

问你有几个人可能会患病

简单题,直接上并查集模板

#include<stdio.h>
#include<string.h>
#define MAXN 30010
int n, m,num,x,y;
int fa[MAXN],size[MAXN];
int find(int x)
{
	return x == fa[x] ? x : x = find(fa[x]);
}
void emerge(int x, int y)
{
	int fx = find(x), fy = find(y);
	if (fx != fy){
		fa[fx] = fy;
		size[fy] += size[fx];
	}
}
int main()
{
	while (~scanf("%d%d", &n, &m))
	{
		if (!n&&!m)
			break;
		for (int i = 0; i <= n; i++)
		{
			fa[i] = i;
			size[i] = 1;
		}
		for (int i = 0; i < m; i++)
		{
			scanf("%d", &num);
			scanf("%d", &x);
			num--;
			while (num--)
			{
				scanf("%d", &y);
				emerge(x, y);
			}
		}
		int tmp = find(0);
		printf("%d\n", size[tmp]);
	}
	return 0;
}