1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<1000<N<1000<N<100, the number of nodes in a tree, and MMM (<N<N<N), the number of non-leaf nodes. Then MMM lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with NNN being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

给你n个结点,当中有m个父亲节点,接下来又m行,每行的分别给父亲节点father,其k个儿子数,接下来k个数代表father的儿子节点,求该棵以1为根节点的树每层的叶子节点数。

思路:DFS遍历这颗树,注意m为0的时候相当于有n个根节点,所以特判一下输出N。

Code

#include <bits/stdc++.h>

using namespace std;
int N,M;
vector<int> Tree[105];
map<int, int > vis;

void DFS (int idx, int k) {
  if (Tree[idx].size() == 0) {
    vis[k]++;
    return ;
  }
  for (int i = 0; i < Tree[idx].size(); i++) {
    DFS(Tree[idx][i], k + 1);
  }
}

int main() {
  int father, son, k;
  cin >> N >>M;
  while (M--) { //build
    cin >> father >> k;
    while (k--) {
      cin >> son;
      Tree[father].push_back(son);
    }
  }
  if (M == 0) {
    cout << N << endl;
  } else {
    DFS(1, 1);
    cout << vis[1];
    for (int i = 2; i <= vis.size(); i++) {
      cout << " " << vis[i];
    }
    cout << endl;
  }
  return 0;
}