Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

Sample Output
4 2 0
 

距离成功只差一步的时候手欠看了题解敲打

想想也知道 else 后面不可能还有dp[i-1][j-1]了啊……还有就是 数组名+1这种整不明白就不用再见

p.s.实验室简直太赞了 1.2M网速 电压也足 可以考虑带电熨板了 哈哈偷笑

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[500][500];
char str1[500],str2[500];
int main()
{
    //freopen("cin.txt","r",stdin);
    while(~scanf("%s%s",str1,str2))
    {
       // printf("%s %s\n",str1,str2);
        memset(dp,0,sizeof(dp));
        int len1=strlen(str1),len2=strlen(str2);
        for(int i=0;i<len1;i++)
            for(int j=0;j<len2;j++)
            {
                if(str1[i]==str2[j])
                    dp[i+1][j+1]=dp[i][j]+1;
                else dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);
            }
        printf("%d\n",dp[len1][len2]);
    }
    return 0;
}