Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.


Input

  • Line 1: Two space separated integers: T and W

  • Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.


Output

  • Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7
2
2
1
1
2
2
1
1


Sample Output

6


Hint

INPUT DETAILS:

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.

OUTPUT DETAILS:

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.


大意:
有两颗苹果树,树下的牛想吃苹果,每秒会从其中一颗树上掉下一个苹果,牛只想移动w次,求在t秒内牛能吃到的最大苹果数量。每次移动都可以看作是瞬间完成的。(牛最开始在第一颗树下)
思路:
dp。设f[x][y]为第x秒时移动y次能达到吃到的最多苹果数量。状态转移方程为f[x][y]=max(f[x-1][y],f[x-1][y-1]+a[i][i%2])。其中a[i][i%2]代表了i秒当前树下是否会掉下苹果。储存苹果时读入x,令a[i][x-1]等于1,代表了第i秒该颗苹果树下会落下苹果。

代码:
i%2那个点子是写题解的时候才想起来的...就没改上去....改了会更简洁一点WWW

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int main(){
    int t, w, i, j, x;
    cin >> t >> w;
    int a[t][2], f[t][w + 1];
    memset(a, 0, sizeof(a));
    memset(f, 0, sizeof(f));
    for (i = 0; i < t;i++){
        cin >> x;
        a[i][x - 1] = 1;
    }
    f[0][0] = a[0][0];
    for (i = 1; i < t;i++){
        f[i][0] += a[i][0] + f[i - 1][0];
    }
    for (j = 0; j <= w;j++){
        if(j%2==0){
            f[0][j] = a[0][0];
        }
        else{
            f[0][j] = a[0][1];
        }
    }
        for (i = 1; i < t; i++)
        {
            for (j = 1; j <= w; j++)
            {
                if (j % 2 == 0)
                {
                    f[i][j] = max(f[i - 1][j] + a[i][0], f[i - 1][j - 1] + a[i][1]);
                }
                else{
                    f[i][j] = max(f[i - 1][j] + a[i][1], f[i - 1][j - 1] + a[i][0]);
            }
        }
    }
    cout << max(f[t - 1][w], f[t - 1][w - 1]);
    return 0;
}