Tree

时间限制: 1000 ms  |  内存限制:65535 KB
难度: 3
 
<dl class="problem&#45;display"> <dt> 描述 </dt> <dd> Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                                D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her!  </dd> </dl>
 
<dl class="others"> <dt> 输入 </dt> <dd> The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file. </dd> <dt> 输出 </dt> <dd> For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root). </dd> <dt> 样例输入 </dt> <dd>
DBACEGF ABCDEFG
BCAD CBAD
</dd> <dt> 样例输出 </dt> <dd>
ACBFGED
CDAB

解题思路:这个题是一样的
</dd> </dl>
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

char pre[30];
char in[30];

void subsquent(int s1,int s2,int n){
    if(n==1){
        printf("%c",pre[s1]);
    }
    if(n<=1){
        return ;
    }
    int i;
    for(i=0;pre[s1]!=in[s2+i];i++);
    subsquent(s1+1,s2,i);
    subsquent(s1+i+1,s2+i+1,n-i-1);
    printf("%c",pre[s1]);
}

int main()
{
    while(scanf("%s %s",pre+1,in+1)!=EOF){
        int n=strlen(pre+1);
        subsquent(1,1,n);
        printf("\n");
    }
    return 0;
}