Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9
一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。
Input
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
Output
输出最长区域的长度。
Sample Input
5 5 1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9
Sample Output
25
把输出看错了,我输出的不是最长步数,而是最长步数的初始位置的值,很坑。
简单题,直接贴代码:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
const int maxn = 1000;
int r,c;
int map[maxn][maxn],dp[maxn][maxn];
int dir[4][2] = {0,1,0,-1,1,0,-1,0};
int dfs(int x,int y){
if(dp[x][y] > 0) return dp[x][y];
int ans = 0;
for(int i = 0;i < 4;i++){
int xx = x + dir[i][0];
int yy = y + dir[i][1];
if(xx < 0 || yy < 0 || xx >= r || yy >= c) continue;
if(map[xx][yy] < map[x][y]){
ans = max(ans,dfs(xx,yy));
}
}
dp[x][y] = ans+1;
return dp[x][y];
}
int main()
{
while(cin>>r>>c){
for(int i = 0;i < r;i++){
for(int j = 0;j < c;j++){
cin>>map[i][j];
dp[i][j] = 0;
}
}
int maxi = 0;
for(int i = 0;i < r;i++){
for(int j = 0;j < c;j++){
maxi = max(maxi,dfs(i,j));
}
}
cout<<maxi<<endl;
}
return 0;
}