题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2165
Time Limit: 2 Seconds Memory Limit: 65536 KB

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and HW and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

  • '.' - a black tile
  • '#' - a red tile
  • '@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Problem solving report:

Description: 一个男人站在黑色的瓷砖上。从瓷砖中,他可以移动到四个相邻瓷砖中的一个。但他不能在红瓦上移动,他只能在黑色瓷砖上移动。求他可以达到的黑色瓷砖的数量。
Problem solving: 简单的DFS搜索。。。

#include <stdio.h>
#define MAXN 20
int n, m, step;
char map[MAXN][MAXN];
int dir[4][2] = {{0, -1}, {1, 0}, {0, 1}, {-1 ,0}};
int DFS(int x, int y) {
    step++;
    map[x][y] = '#';
    for (int k = 0; k < 4; k++) {
        int tx = x + dir[k][1];
        int ty = y + dir[k][0];
        if (tx >= 0 && tx < n && ty >= 0 && ty < m && map[tx][ty] == '.')
            DFS(tx, ty);
    }
    return step;
}
int main() {
    int ex, ey;
    while (scanf("%d%d", &m, &n), n + m) {
        step = 0;
        for (int i = 0; i < n; i++) {
            for (int j = 0; j < m; j++) {
                scanf(" %c", &map[i][j]);
                if (map[i][j] == '@')
                    ex = i, ey = j;
            }
        }
        printf("%d\n", DFS(ex, ey));
    }
    return 0;
}