题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1716
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Ray又对数字的列产生了兴趣:
现有四张卡片,用这四张卡片能排列出很多不同的4位数,要求按从小到大的顺序输出这些4位数。

Input

每组数据占一行,代表四张卡片上的数字(0<=数字<=9),如果四张卡片都是0,则输入结束。

Output

对每组卡片按从小到大的顺序输出所有能由这四张卡片组成的4位数,千位数字相同的在同一行,同一行中每个四位数间用空格分隔。
每组输出数据间空一行,最后一组数据后面没有空行。

Sample Input

1 2 3 4
1 1 2 3
0 1 2 3
0 0 0 0

Sample Output

1234 1243 1324 1342 1423 1432
2134 2143 2314 2341 2413 2431
3124 3142 3214 3241 3412 3421
4123 4132 4213 4231 4312 4321

1123 1132 1213 1231 1312 1321
2113 2131 2311
3112 3121 3211

1023 1032 1203 1230 1302 1320
2013 2031 2103 2130 2301 2310
3012 3021 3102 3120 3201 3210

Problem solving report:

Description: 输出所有的全排列。
Problem solving: 利用C++里面的全排列函数,注意输出格式。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
int s[5], spt[30];
int main() {
    int t = 0;
    while (true) {
        int ans = 0, k = 0;
        for (int i = 0; i < 4; i++) {
            scanf("%d", &s[i]);
            ans += s[i];
        }
        if (!ans)
            break;
        if (!t)
            t = 1;
        else printf("\n");    
        sort(s, s + 4);
        do {
            spt[k] = 0;
            for (int i = 0; i < 4; i++)
                spt[k] = spt[k] * 10 + s[i];
            if (spt[k] >= 1000)
                k++;
        }while (next_permutation(s, s + 4));
        for (int i = 0; i < k - 1; i++) {
            if (spt[i] / 1000 != spt[i + 1] / 1000)
                printf("%d\n", spt[i]);
            else printf("%d ", spt[i]);
        }
        printf("%d\n", spt[k - 1]);
    }
    return 0;
}