题干:

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.

Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

题目大意:

      一个长度为k的窗口,向右滑动,要求输出每一次滑动,窗口内元素的最小值和最大值。(这样的话每行输出的元素就应该是n-k+1个元素咯,因为滑动的窗口从【1-1】先得增长到【1-k】吧)

解题报告:

      双端队列,也可以用模拟双端队列做。

ac代码:(用G++编译器提交 4829ms,用C++编译器 超时,将其中的cout改成printf后,G++,C++编译器均超时。。。)

#include<iostream>
#include<cstdio>
#include<deque>
const int MAX=1000000 + 5 ;
using namespace std;
struct Node {
    int x;
    int index;
} s[MAX];
int n,k;
void Min_Max()
{
    deque<Node>dq;
    for(int i=1; i<=k; i++) {
        while(!dq.empty() && s[i].x<dq.back().x) dq.pop_back();
        dq.push_back(s[i]);
    }
    printf("%d",dq.front().x);
    for(int i=k+1; i<=n; i++)
    {
        while(!dq.empty() && s[i].x<dq.back().x) dq.pop_back();
        dq.push_back(s[i]);
        while(dq.back().index-dq.front().index>=k) dq.pop_front();
        printf(" %d",dq.front().x);
    }
    cout<<endl;
}
void Max_Min()
{
    deque<Node>q;
    for(int i=1; i<=k; i++) {
        while(!q.empty() && s[i].x>q.back().x) q.pop_back();
        q.push_back(s[i]);
    }
    printf("%d",q.front().x);
    for(int i=k+1; i<=n; i++) {
        while(!q.empty() && s[i].x>q.back().x) q.pop_back();
        q.push_back(s[i]);
        while(q.back().index-q.front().index>=k) q.pop_front();
        printf(" %d",q.front().x);
    }
}
int main()
{
    scanf("%d %d",&n,&k);
    for(int i=1; i<=n; i++) {
        scanf("%d",&s[i].x);
        s[i].index=i;
    }
    Min_Max();
    Max_Min();
}

AC代码:(C++编译器9266ms,G++编译器超时)

#include <iostream>
#include <cstdio>
#include <queue>
#include <deque>
 
using namespace std;
typedef pair<int, int> P;
#define maxn 1000000 + 10
 
deque<P> Q1;
deque<P> Q2;
int n, k;
int Min[maxn], Max[maxn];
 
int main()
{
    while(~scanf("%d%d", &n, &k))
    {
        while(!Q1.empty()) Q1.pop_back();
        while(!Q2.empty()) Q2.pop_back();
        int x;
        for(int i=1; i<=n; i++)
        {
            scanf("%d", &x);
            while(!Q1.empty() && Q1.back().first >= x) Q1.pop_back();
            Q1.push_back(P(x, i));
            if(i >= k)
                {
                    while(!Q1.empty() && Q1.front().second <= i-k) Q1.pop_front();
                    Min[i] = Q1.front().first;
                }
 
            while(!Q2.empty() && Q2.back().first <= x) Q2.pop_back();
            Q2.push_back(P(x, i));
            if(i >= k)
                {
                    while(!Q2.empty() && Q2.front().second <= i-k) Q2.pop_front();
                    Max[i] = Q2.front().first;
                }
        }
 
        for(int i=k; i<=n; i++)
            i == n ? printf("%d\n", Min[i]) : printf("%d ", Min[i]);
 
        for(int i=k; i<=n; i++)
            i == n ? printf("%d\n", Max[i]) : printf("%d ", Max[i]);
    }
    return 0;
}

总结:

     怎么解决一下超时问题?