Two different circles can have at most four common tangents.

The picture below is an illustration of two circles with four common tangents.

Now given the center and radius of two circles, your job is to find how many common tangents between them.

Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, there is one line contains six integers x1 (−100 ≤ x1 ≤ 100), y1 (−100 ≤ y1 ≤ 100), r1 (0 < r1 ≤ 200), x2 (−100 ≤ x2 ≤ 100), y2 (−100 ≤ y2 ≤ 100), r2 (0 < r2 ≤ 200). Here (x1, y1) and (x2, y2) are the coordinates of the center of the first circle and second circle respectively, r1 is the radius of the first circle and r2 is the radius of the second circle.

Output

For each test case, output the corresponding answer in one line.

If there is infinite number of tangents between the two circles then output -1.

Sample Input
3
10 10 5 20 20 5
10 10 10 20 20 10
10 10 5 20 10 5
Sample Output
4
2
3

其实就是考察数学知识,判断两圆圆心距和两圆半径的关系,以及判断各种位置对应的共同切线条数:

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int main(){
	int t;
	cin>>t;
	int x1,y1,r1,x2,y2,r2;
	while(t--){
		int cdis,dis;
		cin>>x1>>y1>>r1>>x2>>y2>>r2;
		cdis=(x1-x2)*(x1-x2)+(y1-y2)*(y1-y2);
		dis=sqrt(cdis);
		if(dis==0&&r1==r2)
		puts("-1");
		else if(r1+r2<dis)
		puts("4");
		else if(r1+r2==dis)
		puts("3");
		else if(abs(r1-r2)==dis)
		puts("1");
		else if(r1+r2>dis&&dis>abs(r1-r2))
		puts("2");
		else  if(dis<abs(r1-r2))
		puts("0");
	}
	return 0;
}