2022年3月17日20:08:12
1042 字符统计 (20 分)
1.【题目描述】
请编写程序,找出一段给定文字中出现最频繁的那个英文字母。
输入格式:
输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。
输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。
输入样例:
This is a simple TEST. There ARE numbers and other symbols 1&2&3...........
输出样例:
e 7
2.【题解】
- 进行大小写转换用 string 的
transform(s.begin(),s.end(),s.begin(),::tolower)
; - 判断
islower()
计数 - 按照题意更新出现频率最高的那个英文字母及其出现次数
- 特别注意:更新是如果次数相等记录字典序小的字母
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef long double ld;
typedef pair<int,int> pii;
const int inf=0x3f3f3f3f;
const int maxn=1e6+5;
void solve(){
string s;
getline(cin, s);
transform(s.begin(),s.end(),s.begin(),::tolower);
//cout << s;
int maxx = 0;
int a[2000] = {
0};
char c=s[0];
for (int i = 0; i < s.size();i++){
if(islower(s[i])){
a[s[i] - '0']++;
//cout <<c<<" "<< maxx << endl;
if(maxx<a[s[i] - '0']){
c = s[i];
maxx = a[s[i] - '0'];
}else if(maxx==a[s[i]-'0']){
if(s[i]<c)c=s[i];
}
}
}
cout << c << " " << maxx;
}
int main(){
solve();
return 0;
}