题干:

As we all know, Coach Gao is a talented chef, because he is able to cook M dishes in the same time. Tonight he is going to have a hearty dinner with his girlfriend at his home. Of course, Coach Gao is going to cook all dishes himself, in order to show off his genius cooking skill to his girlfriend.

To make full use of his genius in cooking, Coach Gao decides to prepare N dishes for the dinner. The i-th dish contains Ai steps. The steps of a dish should be finished sequentially. In each minute of the cooking, Coach Gao can choose at most Mdifferent dishes and finish one step for each dish chosen.

Coach Gao wants to know the least time he needs to prepare the dinner.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= N, M <= 40000). The second line contains N integers Ai (1 <= Ai <= 40000).

Output

For each test case, output the least time (in minute) to finish all dishes.

Sample Input

2
3 2
2 2 2
10 6
1 2 3 4 5 6 7 8 9 10

Sample Output

3
10

题目大意:

有一个人要做n道菜,给出每道菜所需步骤数。已知这个人每次同时能做m道菜的1步。问最少需要几次把这些菜做完。

解题报告:

   贪心证明出答案是max( suma(a[i]) / m  ,  max(a[i]) )。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
using namespace std;
typedef long long ll;
const int maxn=20010;
int n,m;
queue<int> q;
int main()
{
	int t,i,j,k,l;
	ll ans,sum,tmp,mx;
	cin>>t;
	for(;t;t--){
		scanf("%d%d",&n,&m);
		sum=0;
		mx=0;
		for(i=0;i<n;i++){
			scanf("%lld",&tmp);
			sum+=tmp;
			mx=max(mx,tmp);
		}
		ans=ceil(sum*1.0/m);
		ans=max(ans,mx);
		printf("%lld\n",ans);
	}
	return 0;
}