Choose the best routeTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 18567 Accepted Submission(s): 6011 Problem Description One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
Input There are several test cases.
Output The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
Sample Output
1 -1 Author dandelion
Source
Recommend lcy | We have carefully selected several similar problems for you: 2112 1874 1217 2066 1142
|
n个车站,m条途径,多个起点和一个终点,没什么可以说的,就是要注意设置一个超级源点0,在最后把他跟所有的起点连一个长度为0的边就行;
不过要注意的是。。。。这道题中边是个单向边。。。;
#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
struct ***
{
int to, len, ne;
}ed[50005];
int head[1005];
int d[1005];
bool vis[1005];
int cnt = 0, n, m, st, en;
void init()
{
cnt = 0;
for (int s = 0; s <= n; s++)
{
head[s] = -1;
vis[s] = 0;
d[s] = 0x3f3f3f3f;
}
}
void add(int from, int to, int len)
{
ed[cnt].to = to;
ed[cnt].ne = head[from];
ed[cnt].len = len;
head[from] = cnt++;
}
void spfa()
{
queue<int>q;
q.push(0);
vis[0] = 1;
d[0] = 0;
while (!q.empty())
{
int t = q.front();
q.pop();
vis[t] = 0;
for (int s = head[t]; ~s; s = ed[s].ne)
{
// cout << s << endl;
if (d[ed[s].to] > d[t] + ed[s].len)
{
d[ed[s].to] = d[t] + ed[s].len;
if (!vis[ed[s].to])
{
q.push(ed[s].to);
vis[ed[s].to] = 1;
}
}
}
}
}
int main()
{
while (~scanf("%d%d%d", &n, &m, &en))
{
init();
while (m--)
{
int a, b, c;
scanf("%d%d%d", &a, &b, &c);
add(a, b, c);
}
int sum;
cin >> sum;
while (sum--)
{
scanf("%d", &st);
add(0, st, 0);
}
spfa();
if (d[en] == 0x3f3f3f3f)
{
printf("-1\n");
}
else
{
printf("%d\n", d[en]);
}
}
return 0;
}