Til the Cows Come Home

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

题意描述:

t条路,n个农场,给出了t条路的起点和终点及权值,路为双向,求n号农场到1号农场的最短路径。

解题思路:

迪杰斯特拉模板题,求出dis[n]即可。

#include<stdio.h>
#include<string.h>
# define inf 99999999
int map[3010][3010],dis[3010],book[3010];
int main()
{
	int n,m,i,j,u,v,min,a,b,c;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(i==j)
					map[i][j]=0;
				else
					map[i][j]=inf;
			}
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(c<map[a][b])
			{
				map[a][b]=c;
				map[b][a]=c;
			}
		}
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++)
			dis[i]=map[1][i];
		book[1]=1;
		for(i=1;i<n;i++)
		{
			min=inf;
			for(j=1;j<=n;j++)
			{
				if(min>dis[j]&&book[j]==0)
				{
					min=dis[j];
					u=j;
				}
			}
			book[u]=1;
			for(v=1;v<=n;v++)
			{
				if(dis[v]>dis[u]+map[u][v])
					dis[v]=dis[u]+map[u][v];
			}
		}
		printf("%d\n",dis[n]);
	}
	return 0;
}