Happy New Term! 
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad. 
What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)? 

Input

There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.

Output

One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .

Sample Input

3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1

3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1

1 1
1 0
2 1

5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10

Sample Output

5
13
-1
-1

题意:给你n个集合,每个集合有一个类型,类型0  你需要从里面至少选一个物品,类型1最多选一个,类型2随便选

问 有T容量的背包,在满足以上条件的基础上,输出获得的最大快乐值

0------对于类型0来说,你需要至少选一个,所以先让他至少选一个

         就是dp[i][j]=max(dp[i][j],dp[i][j-w]+v);

         然后再通过上一个集合的状态来转移

         dp[i][j]=max(dp[i][j],dp[i-1][j-w]+v);

1------最多选一个,就说让他每次都从上一个集合转移过来,每次选的时候都是第一次选或者不选,保证最多一次

         dp[i][j]=max(dp[i][j],dp[i-1][j-w]+v);

2------随便选,简单的01背包

代码如下

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
#define INF 0x3f3f3f3f
#define ll long long
#define pb push_back
using namespace std;
int n,T,m,s,w,v;
int dp[205][205];
int main()
{
    while(~scanf("%d%d",&n,&T))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&m,&s);
            if(s==0)
            {
                for(int j=0;j<=T;j++)
                    dp[i][j]=-INF;
                while(m--)
                {
                    scanf("%d%d",&w,&v);
                    for(int j=T;j>=w;j--)
                    {
                        //注意顺序,颠倒了顺序也会错
                        dp[i][j]=max(dp[i][j],dp[i][j-w]+v);//这不是第一次选,保证了至少选一次
                        dp[i][j]=max(dp[i][j],dp[i-1][j-w]+v);//第一次选
                    }
                }
            }
            else if(s==1)
            {
                for(int j=0;j<=T;j++)
                    dp[i][j]=dp[i-1][j];
                while(m--)
                {
                    scanf("%d%d",&w,&v);
                    for(int j=T;j>=w;j--)
                        dp[i][j]=max(dp[i][j],dp[i][j-w]+v);//第一次选

                }
            }
            else//2类型就是一个简单的01背包了
            {
                for(int j=0;j<=T;j++)
                    dp[i][j]=dp[i-1][j];//需要再上一组的基础上进行dp
                while(m--)
                {
                    scanf("%d%d",&w,&v);
                    for(int j=T;j>=w;j--)
                    {
                        dp[i][j]=max(dp[i][j],dp[i][j-w]+v);
                        dp[i][j]=max(dp[i][j],dp[i-1][j-w]+v);
                    }
                }
            }
        }
        int ans=max(dp[n][T],-1);//如果不如-1大,那么就是不符合条件,输出-1;
        printf("%d\n",ans);
    }
    return 0;
}