1001_Add_More_Zero

题目:

Problem Description
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2^m-1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10^k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.

Input
The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1≤m≤10^5.

Output
For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input
1
64

Sample Output
Case #1: 0
Case #2: 19

这道题目的意思是:给出一个m,计算2^m-1有多少位数,m的取值范围是1~10^5.按常规方法计算肯定数值溢出,不管是double还是long long。因为这个数是指数级形式增长的,2的100000次方是一个天文数字。所以,不能直接计算。

我的做法是对其取对数。公式 2^m >= 10^k ==>> k = log10 (2^m) == >> k=m * log10 (2)
这个k就是原来2^m的位数。

代码如下:

#include<iostream>
#include<cmath>

using namespace std;
/* *用公式k=log10 (2) * m 就可以求出,其中m是2的指数,k是要求的位数 */
int main()
{
    int  m = 0;
    int kase = 0;
    double s = log10(2);
    while (cin >> m && m) {
        double sum = m* s;
        cout << "Case #" << ++kase << ": " << (int)sum << endl;
    }
    return 0;
}

这是道水题,开赛2分钟就有人AC了,而那时候我才刚登录进去。。。。。