PAT A1031

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.
Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <string>
#include <vector>
#include <cstring>
#include <cmath>
#include <set>
#include <queue>
#include <algorithm> 
#include <bitset>
#include <sstream> 
#include <iomanip>

using namespace std;





int main(){

    string str;

    cin>>str;

    int hei,wid;

    int len=str.length();

    hei= (len+2)/3;

    wid = len+2-2*hei;


    for(int i=0;i<hei-1;i++){

        cout<<str[i];

        for(int i=0;i<wid-2;i++){
            cout<<" ";
        }

        cout<<str[len-1-i]<<endl;

    }

    for(int i=0;i<wid;i++){
        cout<<str[hei-1+i];
    }

    cout<<endl;


    return 0;
}