题干:

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 
 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop. 

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers. 

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

解题报告:

   就是题目比较难懂啊。。。大概意思是一群人白天从CCS(一号顶点)出发前往各个点,然后晚上再从各个点回到CCS,问你最小花费是多少。不知道题干扯了这么多没用的是干嘛。。。直接正反跑两遍DIjkstra就可以。

AC代码:

#include<cstdio>
#include<queue>
#include<cstring>
#include<iostream>
#include<algorithm>
#define ll long long
using namespace std;
const int MAX = 1000000 + 5;
int n,m;
int cnt;
int a[MAX],b[MAX];
int head[MAX];
bool vis[MAX];
ll c[MAX],dis1[MAX],dis2[MAX];
struct Edge {
    int to;
    ll w;
    int ne;
} e[MAX];
struct Point {
    int pos;
    ll c;
    Point(){}
    Point(int pos,int c):pos(pos),c(c){};
    bool operator < (const Point b) const {
        return c>b.c;
    }
};
void Dijkstra(ll dis[]) {
    memset(vis,0,sizeof(vis));
    for(int i = 1; i<=n; i++) dis[i] = 9999999999;
    dis[1] = 0;
    priority_queue<Point> pq;
    Point cur = Point(1,0);
    pq.push(cur);
    while(!pq.empty()) {
        cur = pq.top();
        pq.pop();
        vis[cur.c] = 1;
        for(int i = head[cur.pos]; i!=-1; i=e[i].ne) {
            if(/*!vis[e[i].to] &&*/ dis[e[i].to] > dis[cur.pos] + e[i].w) {
                dis[e[i].to ] = dis[cur.pos ] + e[i].w;
                pq.push(Point(e[i].to,dis[e[i].to ]) );
            }
        }
    }

}
void init() {
    memset(vis,0,sizeof(vis));
    memset(head ,-1,sizeof(head));
    cnt = 0;
}
void add(int u,int v,int w) {
    e[cnt].to = v;
    e[cnt].w = w;
    e[cnt].ne = head[u];
    head[u] = cnt++;
}
int main()
{
    int t;
    cin>>t;
    while(t--) {
        init();
        scanf("%d%d",&n,&m);
        for(int i = 1; i<=m; i++) {
            scanf("%d%d%lld",&a[i],&b[i],&c[i]);
            add(a[i],b[i],c[i]);
        }
 //       cout<<"jintu1111"<<endl;
        Dijkstra(dis1);
 //       cout<<"jintu1111"<<endl;
        //第两遍初始化
        init();
        for(int i = 1; i<=m; i++) {
            add(b[i],a[i],c[i] );
        }
  //      cout<<"jintu2222"<<endl;
        Dijkstra(dis2);
  //      cout<<"jintu2222"<<endl;
        ll sum = 0;
        for(int i = 1; i<=n; i++) {
            sum +=dis1[i]+dis2[i];
        }
        printf("%lld\n",sum);
    }

    return 0 ;
}

总结:

    head别初始化成0了。。。dis别忘初始化,,这里是longlong类型所以初始化成9999999999就行。。。显然这题要用longlong啊看看数据范围就知道了。