</pre></h1><h1 style="color: rgb(26, 92, 200);"><pre code_snippet_id="1817132" snippet_file_name="blog_20160808_1_606196" name="code" class="cpp"><span style="font-family: Arial, Helvetica, sans-serif; font-size: 12px; background-color: rgb(255, 255, 255);">Price List</span>
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 536    Accepted Submission(s): 332



Problem Description
There are n shops numbered with successive integers from 1 to n in Byteland. Every shop sells only one kind of goods, and the price of the i-th shop's goods is vi.

Every day, Byteasar will purchase some goods. He will buy at most one piece of goods from each shop. Of course, he can also choose to buy nothing. Back home, Byteasar will calculate the total amount of money he has costed that day and write it down on his account book.

However, due to Byteasar's poor math, he may calculate a wrong number. Byteasar would not mind if he wrote down a smaller number, because it seems that he hadn't used too much money.

Please write a program to help Byteasar judge whether each number is sure to be strictly larger than the actual value.
 

Input
The first line of the input contains an integer T (1T10), denoting the number of test cases.

In each test case, the first line of the input contains two integers n,m (1n,m100000), denoting the number of shops and the number of records on Byteasar's account book.

The second line of the input contains n integers v1,v2,...,vn (1vi100000), denoting the price of the i-th shop's goods.

Each of the next m lines contains an integer q (0q1018), denoting each number on Byteasar's account book.
 

Output
For each test case, print a line with m characters. If the i-th number is sure to be strictly larger than the actual value, then the i-th character should be '1'. Otherwise, it should be '0'.
 

Sample Input
1 3 3 2 5 4 1 7 10000
 

Sample Output
001
 

Source

BestCoder Round #86 



思路:

这道题的意思就是说这个人每天会都到那几个店里去,然后给你定物品的价格了,然后会输入m条消费记录(记录的是每天的总花费),让你依次判断每天是不是一定会比他的商品的总价低(也就是所说的记少了)。很水的一道题。


代码:

#include<cstdio>

long long a[100000];
long long b[100000];


int main()
{
    long long num;
    scanf("%lld",&num);
    for(int i=0;i<num;i++)
    {
            long long sum=0;
            long long m,n;
            scanf("%lld%lld",&m,&n);
            for(int j=0;j<m;j++)
            {
            scanf("%lld",&a[j]);
            sum+=a[j];
            }
            for(int j=0;j<m;j++)
            {
            scanf("%lld",&b[j]);
            if(b[j]<=sum)a[j]=0;
            else a[j]=1;
            }
            for(int j=0;j<n;j++)
            printf("%lld",a[j]);
            //stem("pause");
            printf("\n");
           
    }           
    return 0;
}