Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

 

给定一个数 查询最小的欧拉函数值大于它的数

先打个表,数值和欧拉函数的差值最小的数就是素数了,所以查素数就可以。

也可以直接暴力查询,但要先排个序降一下复杂度

暴力查询:

#include <bits/stdc++.h>
using namespace std;
const int N=1e6+50;
int euler[N],prime[N];
bool vis[N];
int tot,n;
void prime_and_euler()
{
    memset(vis,0,sizeof(vis));
    euler[1]=1;
    tot=0;
    for(int i=2;i<N;i++)
    {
        if(!vis[i])
        {
            prime[tot++]=i;
            euler[i]=i-1;
        }
        for(int j=0;j<tot;j++)
        {
            if(i*prime[j]>N)
                break;
            vis[i*prime[j]]=1;
            if(i%prime[j]==0)
            {
                euler[i*prime[j]]=euler[i]*prime[j];
                break;
            }
            else
                euler[i*prime[j]]=euler[i]*(prime[j]-1);
        }
    }
}
int main()
{
    prime_and_euler();
    int t,n,a[10020];
    scanf("%d",&t);
    for(int k=1;k<=t;k++)
    {
        scanf("%d",&n);
        long long ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+n);
        int tmp=2;
        for(int i=0;i<n;i++)
        {
            for(int j=tmp;j<N;j++)
            {
                if(euler[j]>=a[i])
                {
                    ans+=j;
                    tmp=j;
                    break;
                }
            }
        }
        cout<<"Case "<<k<<": "<<ans<<" Xukha"<<'\n';
    }
    return 0;
}