|
BombTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)Total Submission(s): 21117 Accepted Submission(s): 7903 Problem Description The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Input The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.
Output For each test case, output an integer indicating the final points of the power.
Sample Input 3150500
Sample Output 0115 Hint From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",so the answer is 15.
Author fatboy_cw@WHU
Source 2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU
Recommend zhouzeyong |
题意:含49 , 套路啊!!!
#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
//#define MOD 1000000007
#define bug1 cout <<"bug1"<<endl
#define bug2 cout <<"bug2"<<endl
#define bug3 cout <<"bug3"<<endl
using namespace std;
typedef long long ll;
const int MAX_N=2e5+5;
int bit[100];
ll dp[100][5];
///有49
ll dfs(int pos,int have,bool lead,bool limit){
if(pos==-1) return (have==2);
if(!limit && !lead && dp[pos][have]!=-1) return dp[pos][have];
int up=limit ? bit[pos] : 9;
ll ans=0;
for(int i=0;i<=up;i++){
int temphave=have;
if(have==0&&i==4) temphave=1;
else if(have==0&&i!=4) temphave=0;
else if(have==1 && i==9) temphave=2;
else if(have==1 && i==4) temphave=1;
else if(have==1 && i!=4) temphave=0;
ans+=dfs(pos-1,temphave,i==0&&lead,limit&&bit[pos]==i);
}
if(!limit && !lead) dp[pos][have]=ans;
return ans;
}
ll solve(ll n){
int pos=0;
while(n){
bit[pos++]=n%10;
n/=10;
}
return dfs(pos-1,0,true,true);//最高位肯定有限制
}
int main(void){
ll n;
int T;
cin >>T;
while(T--){
scanf("%lld",&n);
memset(dp,-1,sizeof(dp));
printf("%lld\n",solve(n));
}
}
你看!踏马是套路题吧!♪(^∇^*)