题目链接:https://vjudge.net/problem/HDU-1242

题目链接:https://vjudge.net/problem/21153/origin

题目

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

题目大意:给你一个地图,a表示天使的位置,#表示墙,. 表示可以走的路,r表示天使的朋友,x表示守卫,

问你他的朋友要去救天使(就是到达天使的地方)。对于守卫,我们可以花费一秒钟打死他,也可以饶过他。

让你求朋友救出天使的最短时间。

思路:

我们可以从天使位置开始bfs,用优先队列,因为守卫的存在,会导致你bfs到各个边界的值时间不同步,所以要用优先队列,让时间花费少的排在前面,。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
using namespace std;
char mp[205][205];
int vis[205][205];
int xa,ya;
int mv[4][2]= {0,1,1,0,0,-1,-1,0};
struct zxc
{
    int x,y,step;

} st,en;
struct cmp{
	bool operator ()(const zxc &a,const zxc &b)
	{
		if(a.step > b.step)
		{
			return true;
		}
		return false;
	}
};

priority_queue<zxc,vector<zxc>,cmp> q;

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(vis,0,sizeof(vis));
        for(int i=0; i<n; i++)
        {
            scanf("%s",mp[i]);
            for(int j=0; j<m; j++)
            {
                if(mp[i][j]=='a')
                {
                    xa=i;
                    ya=j;
                }
            }
        }
        st.x=xa,st.y=ya;
        vis[xa][ya]=1;
        st.step=0;
        q.push(st);
        int flog=0;
        while(!q.empty())
        {
            st=q.top();
            q.pop();
            if(mp[st.x][st.y]=='r')
            {
                flog=1;
                printf("%d\n",st.step);
                break;
            }
            for(int i=0; i<4; i++)
            {
                en.x=st.x+mv[i][0];
                en.y=st.y+mv[i][1];
                if(en.x<0||en.x>=n||en.y<0||en.y>=m||vis[en.x][en.y]==1||mp[en.x][en.y]=='#')
                {
                    continue;
                }
                else
                {
                    if(mp[en.x][en.y]=='x')
                    {
                        en.step=st.step+2;
                    }
                    else
                    {
                        en.step=st.step+1;

                    }
                    vis[en.x][en.y]=1;
                    q.push(en);

                }
            }

        }
        if(!flog)
        {
            printf("Poor ANGEL has to stay in the prison all his life.\n");
        }
    }

    return 0;
}