题目链接:http://poj.org/problem?id=2253
Time Limit: 1000MS Memory Limit: 65536K

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Problem solving report:

Description: 给出每个点的坐标,找出从1到2的路径中需要最少跳多远。
Problem solving: 最短路变形题,利用Dijkstra稍微变一下松弛条件。

Accepted Code:

#include <cmath>
#include <queue>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 205;
const int MAXM = 10005;
const int inf = 0x3f3f3f3f;
struct point {
    int x, y;
}p[MAXN];
bool vis[MAXN];
double mp[MAXN][MAXN], dis[MAXN];
double dist(const point &a, const point &b) {
    return sqrt(1.0 * (a.x - b.x) * (a.x  - b.x) + (a.y - b.y) * (a.y - b.y));
}
double Dijkstra(int s, int t, int n) {
    for (int i = 1; i <= n; i++) {
        dis[i] = inf;
        vis[i] = false;
    }
    dis[s] = 0;
    vis[s] = true;
    for (int i = 1; i < n; i++) {
        int min_ = inf, k = s;
        for (int j = 1; j <= n; j++)
            if (!vis[j] && dis[j] < min_)
                min_ = dis[k = j];
        vis[k] = true;
        for (int j = 1; j <= n; j++)
            if (!vis[j] && dis[j] > max(dis[k], mp[k][j]))//这里变了一下
                dis[j] = max(dis[k], mp[k][j]);
    }
    return dis[t];
}
int main() {
    int n, kase  = 0;
    while (scanf("%d", &n), n) {
        for (int i = 1; i <= n; i++) {
            scanf("%d%d", &p[i].x, &p[i].y);
            for (int j = 1; j < i; j++)
                mp[i][j] = mp[j][i] = dist(p[i], p[j]);
        }
        printf("Scenario #%d\nFrog Distance = %.3f\n\n", ++kase, Dijkstra(1, 2, n));
    }
    return 0;
}