题干:
A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.
In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".
An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car".
Input
The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
Output
The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
Sample Input
carbohydrate cart carburetor caramel caribou carbonic cartilage carbon carriage carton car carbonate
Sample Output
carbohydrate carboh cart cart carburetor carbu caramel cara caribou cari carbonic carboni cartilage carti carbon carbon carriage carr carton carto car car carbonate carbona
题目大意:
输入N个单词,输出N个单词本身以及在该单词在字典中不会与其他单词混淆的最短前缀缩写。
解题报告:
裸的字典树。。不解释。注意字符串的读入方法和rt每次查询的初始化就可以了。。。但是这题好像不用初始化也可以AC不知道为什么、、、
AC代码:
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
char a[10001][31];
int tot,size;
int sz,trie[300001][26],s[300001];
void insert(char ch[]) {
int len=strlen(ch),rt=0;
for(int i=0; i<len; i++) {
int cur=ch[i]-'a';
if(trie[rt][cur]==0) trie[rt][cur]=++sz;
rt=trie[rt][cur];
s[rt]++;
}
}
void ask(char ch[]) {
int now=0,rt=0,len=strlen(ch);
for(int i=0; i<len; i++) {
int cur = ch[i]-'a';
printf("%c",ch[i]);
rt=trie[rt][cur];
if(s[rt]==1) break; //也可以放到int cur = ch[i] - 'a'上面
}
}
int main() {
char str[1005];
while(~scanf("%s",str)) {
tot++;
strcpy(a[tot],str);insert(a[tot]);
}
for(int i=1; i<=tot; i++) {
printf("%s ",a[i]);
ask(a[i]);
printf("\n");
}
return 0;
}