Lilin was a student of Tonghua Normal University. She is studying at University of Chicago now. Besides studying, she worked as a tutor teaching Chinese to Americans. So, she can earn some money per month. At the end of the year, Lilin wants to know his average monthly money to decide whether continue or not. But she is not good at calculation, so she ask for your help. Please write a program to help Lilin to calculate the average money her earned per month.

Input

The first line contain one integer T, means the total number of cases.
Every case will be twelve lines. Each line will contain the money she earned per month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average of money she earned for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign without tail zero. There will be no other spaces or characters in the output.

Sample Input

2 
100.00 
489.12 
12454.12 
1234.10 
823.05 
109.20 
5.27 
1542.25 
839.18 
83.99 
1295.01 
1.75
100.00 
100.00 
100.00 
100.00 
100.00 
100.00 
100.00 
100.00 
100.00 
100.00 
100.00 
100.00

Sample Output

$1581.42 
$100

求12个月工资的平均值,四舍五入保留两位小数,输出不能有尾零

#include<cstdio>
using namespace std;
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		double x,ans=0;
		for(int i=1;i<=12;i++){
			scanf("%lf",&x);
			ans+=x;
		}
		
		int k=(int)((ans/12+0.005)*100);
		ans=((double)k)/100;
		if(k%100==0){
		   printf("$%.0f\n",ans);
		}
		else if(k%10==0){
			printf("$%.1f\n",ans);
		}
		else {
			printf("$%.2f\n",ans);
		}	
	}
	return 0;
}