题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3613
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Problem Description

After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit. 

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.) 

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li. 

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero. 

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value. 

Input

The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows. 

For each test case, the first line is 26 integers: v1, v2, ..., v26 (-100 ≤ vi ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind. 

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v1, the value of 'b' is v2, ..., and so on. The length of the string is no more than 500000. 

Output

Output a single Integer: the maximum value General Li can get from the necklace.

Sample Input

2
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
aba
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
acacac

Sample Output

1
6

Problem solving report:

Description: 把一个串分割成两个,求出最大权值(不是回文串则权值为0)
Problem solving: 将原串反转得s2,然后用原串s1去匹配s2,最终s1匹配到的位置就是s1的最大前缀回文串。
同理用s2去匹配s1得到s2的最大前缀回文串,即s1得最大后缀回文串,然后根据next[k]的特性,next[k]跳转到的位置就是下一个前缀回文串(0~k和x~len相同,而x~len又是0~k反转得到的,所以0~k是回文串),直到k=0,将所有前缀回文串和后缀回文串标记,然后对原串线性扫描求出最大值即可。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
const int MAXN = 500005;
const int inf = 0x3f3f3f3f;
char str[MAXN], str_[MAXN];
bool vist[MAXN], visp[MAXN];
int v[30], nex[MAXN], ans[MAXN];
void Next(char str[], int len) {
    nex[0] = -1;
    int i = 0, j = -1;
    while (i < len) {
        if (~j && str[i] != str[j])
            j = nex[j];
        else nex[++i] = ++j;
    }
}
int KMP(char sa[], char sb[], int len) {
    Next(sb, len);
    int i = 0, j = 0;
    while (i < len && j < len) {
        if (~j && sa[i] != sb[j])
            j = nex[j];
        else i++, j++;
    }
    return j;
}
int main() {
    int t, l, len;
    scanf("%d", &t);
    while (t--) {
        memset(vist, false, sizeof(vist));
        memset(visp, false, sizeof(visp));
        for (int i = 0; i < 26; i++)
            scanf("%d", &v[i]);
        scanf("%s", str);
        len = strlen(str);
        for (int i = 0; i < len; i++) {
            str_[len - i - 1] = str[i];
            ans[i + 1] = ans[i] + v[str[i] - 'a'];
        }
        l = KMP(str_, str, len);
        while (l) {
            vist[l] = true;
            l = nex[l];
        }
        l = KMP(str, str_, len);
        while (l) {
            visp[l] = true;
            l = nex[l];
        }
        int max_ = -inf;
        for (int i = 1; i < len; i++) {
            int cnt = 0;
            if (vist[i])
                cnt += ans[i];
            if (visp[len - i])
                cnt += ans[len] - ans[i];
            max_ = max(max_, cnt);
        }
        printf("%d\n", max_);
    }
    return 0;
}